Browser Problems

Discussion in 'Questions' started by RufusXZ, Feb 14, 2019.

  1. RufusXZ

    RufusXZ Member

    Joined:
    Jul 14, 2018
    I am currently playing on my PC in 3 Worlds and I am using Opera as my browser.
    I decided to change my browser to EDGE so I tried to open FORGE of EMPIRES from the Bing search engine.
    I can't get back to my existing account! The FoE login page doesn't recognize my user name, my email address nor password.

    Thanks
    RufusXZ
     
  2. MandyTheAlabastard

    MandyTheAlabastard Active Member

    Joined:
    Feb 3, 2019
    Perhaps you mistyped something? Next time, you should have had a small sticky note in a well-concealed area with your username, password and email address in case you forgot the account. Talk to support and see if they can recover your account. Sorry for you having to go through this.
     
  3. Roxana 1184 the Wise

    Roxana 1184 the Wise Well-Known Member

    Joined:
    Oct 16, 2018
    Make sure you are in the US server. The result from Bing may have sent you to the EN server, so make sure it says us.forgeofempires.com. Also some of those results may not be FOE, but rather scam sites set up to look like FOE (hopefully not, as you would have now sent your login info to some scammer).
     
  4. RufusXZ

    RufusXZ Member

    Joined:
    Jul 14, 2018
    LOL I do indeed have everything written down and believe me I tried it more than once.
    I am back into my worlds as I just went back to my old browser.

    I am hoping support will see this and maybe have an answer. I would definitely like to change to the Edge Browser since I am running the WIN10 operating system.

    Thank you ROXANA 1184, I just saw your answer as I was typing this and that is a good point.

    I will loin again using EDGE but check on the server status first. Great point

    Thanks
    RufusXZ
     
  5. wjblaney

    wjblaney Member

    Joined:
    Sep 6, 2017
    I had the same problem when I bought a new computer. The new computer, or new browser, may find a different FoE address which looks identical to the old one, as strange as that sounds (when I looked at the 2 urls, old and new, I couldn't see anything different). Go back to using your Opera browser and bookmark that login on your taskbar. Use that bookmark when you are working with Edge. Worked for me.
     
  6. BruteForceAttack

    BruteForceAttack Well-Known Member

    Joined:
    Dec 2, 2015
    Have you tried with Opera again?
     
  7. RufusXZ

    RufusXZ Member

    Joined:
    Jul 14, 2018
    I tried OPERA again and everything works fine. I am actually logged in to my 3 worlds at the present.
    I haven't gone back to EDGE yet and ....Thank you wjblaney.! That's a good idea
     
  8. RufusXZ

    RufusXZ Member

    Joined:
    Jul 14, 2018
    The problem is SOLVED with the EDGE Browser.
    Since my language is English, the LINK from the BING search engine defaults to InnoGames English Server. I live in Canada and the USA Server is used for my Country,
    Once I changed the Inno Service to United States, I was able to login normally and now can use either Opera or Edge Browsers

    Thanks all
    RufusXZ
     

Top