Not A Bug FoE freezing since last update

Dabeeto

Member
Browser: Chrome

DONE - Refresh your browser (F5: soft refresh and CTRL+F5: hard refresh).
DONE - Clear your browser's cache (temporary internet files). --> Link
DONE - Try a different (up to date) browser.
DONE - Make sure you use the newest Flash Player --> Link
DONE - Delete your cookies.
DONE - Temporarily disable all (greasemonkey) scripts and browser add-ons. --> Link 1 - Link 2
DONE - Log out / Log in
DONE - Restart your computer.
- Try a different computer.
- Try a different internet connection.
- Temporarily disable your firewall and your anti virus program. Do this only for a quickcheck. After that, enable your security system immediately again!

Btw, I'm a level 2 IT professional, I mention this because I find it useful to know people's experience level with computers, personally.

Also, note, I am running Pandora in another tab.

Whenever I tab away from FoE, it freezes. Everything is still visible, but the animations are frozen and nothing responds when clicked on. This is on my city screen, with nothing else open. It happens as soon as I switch tabs. It works fine until I do so. I've played this same way for 6 months this way, and this is the first time I've seen this problem.
 

Robbenn

New Member
I am experiencing game freezes as well since last update when I try to visit the GB list of other players. It happens about 70/80% of the time. Funny thing is, in changelog 1.104 they said they fixed some bug where the game would get unresponsive, but the problem appeared only now... after they allegedly fixed it.
 

Snowbelle

Well-Known Member
If you are experiencing game freezes as suggested first clear flash, second try a different browser. I personally like Opera for the game. If none of that works, contact support. They would be happy to help.
 

Brigadator

New Member
I too am experiencing this freezing on my comp. I've tried different computers and different browsers. Looks like only a hard refresh and re-logging into the game is the only thing that helps. But it could easily happen over again when I tab away and then back.
 

Maestro

Active Member
Some players started experiencing the problem with the game ‘freezing’ from time to time. The reason of this issue is that in the last Chrome version (v59), the screen is being ‘cached’, so in certain circumstances, for instance when you switch tabs and then switch back, it can happen that the game appears frozen. In fact, it's 'just' the cached screen. Underneath, the game is running and it’s fully functional, it just doesn't visualize it in the browser. Therefore, there is little we can do from our side, as we cannot detect anything wrong (after all: the game runs flawlessly beneath). If there is a possible fix, I will update you, of course .Naturally, as this is a problem for us (and for many other games, too), this was already reported to the browser’s developers. Resizing the screen or opening the console (F12) may be a workaround for users, while we're waiting for Google to resolve the issue.
 

Maestro

Active Member
I have labeled this not a bug as it isn't a bug with FOE, the issue is with chrome...but will leave this up for a little while in case Google comes out with instructions on how to deal with it.
 

Kataphractos

I thought I should let you know:

I play on PC, through Firefox. Last evening, the game refused to load, no matter how many times I did a hard-refresh or cleared my browser cache. It always froze somewhere between the 70% and 80% mark, right about the time the cursor switches over. The game would only finish loading if I turned off my anti-virus program (Avast Antivirus). Also, it froze every time I tried to access my own tavern, or sit in another player's tavern; sometimes it wouldn't even display the shield-and-crossed-swords. I'm still experiencing both those problems today.

Whether or not this counts as a "bug", it makes the game effectively unplayable, especially on a long-term basis. And it's not only a Google Chrome problem...which should have been apparent when Brigadator and Tstar99 reported they were having the same problem with non-Chrome browsers. I apologize if that sounds harsh.
 

Maestro

Active Member
I think you folks are talking about two separate issues...the initial ticket and issue described on it is a problem with chrome...if you read the description of the issue and my reply they are both related to chrome. The rest of you running a non chrome browser are a different issue. Please repost your issue and give as many details as you can including browser type...in a new post...as we have resolved the original issue mentioned here.
 

Kataphractos

Thank you, Maestro! I think I've located the more appropriate thread for this issue: "Game will not load past 70%", in the "Confirmed Bugs" sub-forum. Apparently it's been a problem since mid-March. I hope Tstar99 and Brigadator are still reading this thread, so they can be directed to that thread!
 

snake11s

Maestro, your response makes perfect logic for the chrome issue and resizing the window is a quick workaround. Thanks for taking the time for a detailed response and not the standard "clear your cache, change browser" answer.
 

qaccy

Well-Known Member
What's interesting to me after reading this topic is that I've used exclusively Chrome for years now (long before I even started playing FoE), and up until now I've never had any browser-specific problem with the game. My game hasn't been freezing when I switch tabs, but why is that? I'm using the same browser (Chrome) as others here in seemingly the same way, yet I haven't been experiencing any problems with it. More to it than just browser, perhaps?
 

Maestro

Active Member
We have submitted some additional information to Microsoft and their technical support team....it is not an issue exclusive to Forge of Empires, it is impacting many games and similar type programs.
 

LoriLPike

New Member
Ive tried Opera and some other browsers. I still have the same issue no matter what. The thing is, this started happening after the last update by Inno.
 

Dabeeto

Member
We have submitted some additional information to Microsoft and their technical support team....it is not an issue exclusive to Forge of Empires, it is impacting many games and similar type programs.
Ty Maestro for responding! I love when companies actually address people's bug reports and/or suggestions!

Did you submit to Google as well? Chrome is google. Also, why does Pandora not freeze, even though it runs off flash? Is there some hidden code that you can insert to tell chrome not to cache the tab? Like personally, I'd submit a question to stackoverflow or another programmer's site asking the programming community for a workaround.
 

Dursland

I am Dursland
Not sure of the answer to that, but there is a rewrite ongoing. First half of 2018 will see FoE switch from Flash to HTML5 which should solve many problems.
 

Queen Cubberly

Active Member
My game ran totally fine until the past year, there was an update and I kept writing Inno after doing all the requested things...refreshing, clearing internet browser, updating flash, all kinds of things. It started happening after a GAME update. It does good for a week or so then it starts freezing up again. I can't even see the words I'm typing in my guild til a few seconds later. I have to stop typing until it catches up. My guildmates are having the exact same problem. I don't think this is my browser. I tried other browsers as well. I do believe and have felt for months now that it's the game.
 

Queen Cubberly

Active Member
In fact, I am froze up right now. My hubby and I can't log into the game. Just keeps loading and loading. Maybe there's maintenence being done, that I missed, but...this happens a lot. My other internet sites/games work just fine.
 

Dursland

I am Dursland
There is currently a bug with flash where the game will freeze if it's being played in a window with more than one tab.

You can either resize the browser window to unfreeze it or play FoE in a separate window with no other tabs.