• We are looking for you!
    Always wanted to join our Supporting Team? We are looking for enthusiastic moderators!
    Take a look at our recruitement page for more information and how you can apply:
    Apply

Not A Bug Game crashing

DevaCat

Well-Known Member
Got the update today from the App Store (iPad, iOS 9.xx)

The app is repeatedly failing to launch, including black screens requiring hard stops to clear.

Once the game loads and the city window initializes (slowly due to game freezes) and any single action is taken, such as collecting an incident or tapping on Tavern to open it, the game crashes.

I have tried turning the device on and off. I would try logging out and then back in, but I cannot as the game crashes when I attempt to open Settings. I have not yet deleted and reinstalled the game. I don't have any faith that would help anyway, as it did not help with these same issues when they appeared with the last update. (Ticket already in on that one; no improvement so far.)
 

Tony 85 the Generous

Active Member
I had the same issue about 9pm Eastern time (not sure the time zone of these posts). Game would load on PC or IOS and hang on load (progress bar stopped 40-45%). BUT only when connected via Comcast/Xfinity ISP. When connected via Verizon Cellular (IOS direct or PC through hotspot) it worked fine.

All seems fine this morning.
 

DevaCat

Well-Known Member
In my case, on the iPad -- yes. Game all but unplayable after last update. Unable to access Event, Research, Inventory, Ge, GBG, CS, due to crashes upon each attempt. Crashing on each RQ abort/selection, opening a gb, etc. After over a week back and forth with Support, seems the game has moved on past the RAM capability of my old device.

Curiously, they insist that my iPad/iOS 9.x is still compatible with the game. ?? I suppose that's true in the sense that I can, with great repeated effort, download and install the game -- I just can't play it.

My daughter gave me an iPhone SE, which so far is working well. I had forgotten how nice the animations are. Tiny little thing though.