Dear Kings and Queens,

On May 21st, Forge of Empires with be updated to version 1.01. This update focuses heavily on bug-fixing, as we try to improve further the overall quality and playing experience of the game. Please see the changelog below for a list of changes:

Changelog 1.01

Features and changes
  • Smoke animations now fade in and out.
  • If a player has no session, they are now directed to the home page.
  • Post-battle summary window now includes military unit tooltips.

  • Added hover to explain world system to players on external world selection page.
  • Users logging in via Facebook now stay logged in even after closing the browser.
  • Players will now be redirected to the login page when they login again from an external location (eg. Google)

  • Some text and grammatical problems have been corrected.

  • Reclaim the Throne - The second condition was triggered when making people happy instead of angry. This has been corrected.
  • The Poison in the Well quest cannot be completed when all research technologies have been unlocked. This problem has now been solved.
  • The quest "Deal with Childerich" could not be triggered with a female avatar. This has been fixed.

  • The add-on sound samples (which get added to the main theme tune) cannot lead to sound errors anymore.
  • The "Save Spoiled Supplies" option was missing after allowing your supplies to spoil while viewing a great buildings construction menu. This problem has now been solved.
  • The Administrate Forums button is no longer off-center in the Guild Forums.
  • When unit name is too long, the "(unattached)" string was being pushed to a second line, causing a graphical issue. This problem now no longer occurs.
  • In the Great Building Reward tool-tip if blueprints are awarded, the name of the great building could be cut off due to the length of the translation. This no longer happens.
  • In rare occurrences, no battle result screen was shown. This is now no longer the case.
  • Unit pop-ups could be too long for the screen. This issue has been fixed.
  • Military buildings were showing the idle symbol during production. This problem has been resolved.
  • In rare instances it was possible to own all sectors without owning the province. This should no longer be an issue.
  • Coins and Supplies were displayed as being subtracted when using the collect all button when a player had certain Great Buildings. The end result was actually correct, but the display was misleading and has now been corrected.
  • Adjusting music settings in some circumstances meant that two tracks could be played at the same time. This problem no longer occurs.
  • Some social bars could display incorrect points. This has been corrected.
  • The loading screen appeared to have different background colors. This problem has been fixed.
  • The New Craigshire province was not red-colored after scouting. This issues has now been corrected.
  • Resizing the window while in the loading screen could cause the screen to get stuck. This has been fixed, and the loading should now also be a bit smoother.
  • Selecting the "go to last page" option in the inventory would display an empty page.
  • Sending an invitation to a nonexistent email address was causing an infinite loading loop. This has now been corrected.
  • The Research Premium button did not count for quests that required you to spend Forge Points. This problem has now been fixed.
  • Well of Welcome, Vitruvian Man and Phoenix Statue now are Bronze Age buildings.
  • The polishing icons for the nutcracker could be incorrectly displayed. This issue no longer occurs.
  • AdBlock Plus anti-social-list blocks Login-Field. This problem has been fixed.
  • Instant research requests reached the server in different order in some cases. This issue has been solved.
  • Some icons in tool-tip headers were misplaced. This has now been corrected.

There may be a short period of downtime during the update, and we apologize for any inconvenience caused by this. Thank you for playing Forge of Empires!

The Forge of Empires team.